Συλλογή ασκήσεων και τεστ στην ΑΕΠΠ

lostpfg

Νεοφερμένος

Ο Πέτρος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών και Φοιτητής . Έχει γράψει 38 μηνύματα.
ΠΡΟΓΡΑΜΜΑ ΑΚΣΗΣΗ_ΕΞ_ΑΣΚΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:j,k,i,ΠΙΝ[100],temp
ΛΟΓΙΚΕΣ:done
ΑΡΧΗ
j <-- 1
ΓΡΑΨΕ 'Δώστε το 1ο στοιχείο του πίνακα'
ΔΙΑΒΑΣΕ ΠΙΝ[1]
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 100
ΓΡΑΨΕ 'Δώστε το ',i,'ο στοιχείο του πίνακα'
ΔΙΑΒΑΣΕ temp
done <-- ΨΕΥΔΗΣ
k <-- 1
ΟΣΟ k<=j ΕΠΑΝΑΛΑΒΕ
ΑΝ temp=ΠΙΝ[k] ΤΟΤΕ
k <-- j
done <-- ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
k <-- k+1
ΤΕΛΟΣ_ΑΝ
ΑΝ done=ΑΛΗΘΗΣ ΤΟΤΕ
k <-- 1
ΓΡΑΨΕ 'Δώστε το ',i,'ο στοιχείο του πίνακα ξανά'
ΔΙΑΒΑΣΕ temp
done <-- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΠΙΝ <-- temp
j <-- j+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Φίλε μια χαρά τρέχει;)!!! δες το στην γλωσσομάθεια για του λόγου το αληθές.....:no1:

:jumpy:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

larkodia

Νεοφερμένος

Ο ανδρεας αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 30 ετών , Μαθητής Γ' λυκείου και μας γράφει απο Καλαμάτα (Μεσσηνία). Έχει γράψει 9 μηνύματα.
καλα ασ΄τα να πανε....αυτοσ ο προγραμματισμοσ ειναι κολαση...
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

lostpfg

Νεοφερμένος

Ο Πέτρος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών και Φοιτητής . Έχει γράψει 38 μηνύματα.
Νομίζω πως δουλέυει..Είναι η άσκηση με του Ρωμαίους...

"Μια μέθοδος παραδειγματισμού που χρησιμοποιούσαν πολλές φορές οι Ρωμαίοι για να αποθαρρύνουν τυχόν στασιαστές στο στράτευμα τους ήταν η εξής: Από τους στασιαστές διάλεγαν 1000 άνδρες που τους τοποθετούσαν σε μία γραμμή. Κατόπιν άρχιζαν να τους εκτελούν ανά δύο. Δηλαδή την πρώτη φορά εκτελούσαν το δεύτερο, τον τέταρτο κλπ. Εάν ο τελευταίος της σειράς επιζούσε, τοποθετούνταν πρώτος στην ευθεία για την επόμενη εκτέλεση. Με τον τρόπο αυτό, τελικά επιζούσε μόνο ένας, ο οποίος αφήνονταν ελεύθερος ώστε να κάνει γνωστή την ιστορία στο υπόλοιπο στράτευμα. Να υλοποιήσετε πρόγραμμα που θα υπολογίζει τη θέση στην αρχική ευθεία των 1000 ατόμων, που θα εξασφαλίζει τη σωτηρία!
"


Λύση


ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ_ΒΛΕΠΩ_ΤΑ_ΡΑΔΙΚΙΑ_ΑΝΑΠΟΔΑ
ΣΤΑΘΕΡΕΣ
Ν=1000
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:i,j,ΠΙΝ[Ν],sum,temp,temp1,temp2[Ν],k
ΑΡΧΗ
!Γέμισμα πίνακα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
ΠΙΝ <-- i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Τροποποίηση πίνακα ΠΙΝ με νέα σείρα με την βοήθεια ενώς πίνακα(temp2)
sum <-- Ν
ΟΣΟ sum<>1 ΕΠΑΝΑΛΑΒΕ
k <-- sum
!Σκοτώνω "μηδενίζοντας" τους νεκρόυς και παράλληλα μετράω το νέο πλήθος(k)
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ sum ΜΕΒΗΜΑ 2
ΠΙΝ <-- 0
k <-- k-1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΠΙΝ[sum]=0 ΤΟΤΕ
i <-- 1
j <-- 1
ΟΣΟ i <=sum ΚΑΙ j<=k ΕΠΑΝΑΛΑΒΕ
ΑΝ ΠΙΝ<>0 ΤΟΤΕ
temp2[j] <-- ΠΙΝ
ΠΙΝ <-- 0
i <-- i+1
j <-- j+1
ΑΛΛΙΩΣ
i <-- i+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
i <-- 1
j <-- 1
ΟΣΟ i <=sum ΚΑΙ j<=k ΕΠΑΝΑΛΑΒΕ
ΑΝ ΠΙΝ<>0 ΤΟΤΕ
temp2[j+1] <-- ΠΙΝ
ΠΙΝ <-- 0
i <-- i+1
j <-- j+1
ΑΛΛΙΩΣ
i <-- i+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
temp2[1] <-- temp2[k+1]
temp2[k+1] <-- 0
ΤΕΛΟΣ_ΑΝ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ k
ΠΙΝ <-- temp2
temp2 <-- 0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Το νέο πλήθος(j) γίνεται sum για τον επόμενο γύρω "του Θανάτου"
sum <-- k
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'Η τυχέρη θέση είναι η ',ΠΙΝ[1],'η'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

dkotanid

Νεοφερμένος

Ο Κοτανίδης Δημήτρης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 42 ετών και Καθηγητής . Έχει γράψει 47 μηνύματα.
ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ_ISCHOOL
!------------------------
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι, Κ
ΛΟΓΙΚΕΣ: ΔΙΑΦ
ΠΡΑΓΜΑΤΙΚΕΣ: Α[100]
!------------------------
ΑΡΧΗ

ΔΙΑΒΑΣΕ Α[1]
! ΔΙΑΒΑΖΩ 1Ο ΣΤΟΙΧΕΙΟ ΠΙΝΑΚΑ

Ι <-
2
ΟΣΟ Ι <= 100
ΕΠΑΝΑΛΑΒΕ

ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ', Ι,
' Ο ΣΤΟΙΧΕΙΟ ΤΟΥ ΠΙΝΑΚΑ'
ΔΙΑΒΑΣΕ Α[Ι]
Κ <-
1
ΔΙΑΦ <-
ΑΛΗΘΗΣ
ΟΣΟ Κ < Ι ΚΑΙ ΔΙΑΦ = ΑΛΗΘΗΣ
ΕΠΑΝΑΛΑΒΕ
ΑΝ Α[Ι] = Α[Κ]
ΤΟΤΕ
ΔΙΑΦ <-
ΨΕΥΔΗΣ
ΑΛΛΙΩΣ
Κ <- Κ +
1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΔΙΑΦ = ΑΛΗΘΗΣ
ΤΟΤΕ
Ι <- Ι +
1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ
100
ΓΡΑΨΕ Α[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



Νομίζω ¨τρέχει¨ ορθώς!
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Eruyomo

Πολύ δραστήριο μέλος

Ο Μάνος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 36 ετών , Φοιτητής και μας γράφει απο Χανιά (Χανιά). Έχει γράψει 1,505 μηνύματα.
Έχοντας ένα δισδιάστατο πίνακα ΝxΜ (Ν,M μεγαλύτερα ή ίσα του 2) με όλα τα στοιχεία του ακέραια, μη αρνητικά και γνωρίζοντας ότι το μικρότερο στοιχείο του έχει την τιμή 0, να βρεθεί το 3o μεγαλύτερο στοιχείο του.

πχ για τον 2x2 πίνακα

1 0
4 5

Το μεγαλύτερο στοιχείο του είναι το 5
το 2ο μεγαλύτερο το 4
το 3ο μεγαλύτερο το 1.
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

marsenis

Νεοφερμένος

Ο Μάκης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 28 ετών , Μαθητής Γ' λυκείου και μας γράφει απο Αθήνα (Αττική). Έχει γράψει 19 μηνύματα.
Εκτός απο τον προφανή αλγόριθμο που προσομοιώνει την διαδικασία, υπάρχει και ένας πιο γρήγορος τρόπος που βρίσκει το αποτέλεσμα κατευθείαν μέσο ενός μαθηματικού τύπου. Φυσικά αυτή η λύση δεν είναι στα πλαίσια του ΑΕΠΠ αφού το δύσκολο κομμάτι είναι να βρείς και να αποδείξεις τον τύπο και όχι να γράψεις το πρόγραμμα. Για περισσότερες πληροφορίες δείτε εδώ: https://en.wikipedia.org/wiki/Josephus_problem
Code:
ΠΡΟΓΡΑΜΜΑ JOSEPHUS
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τον αριθμό των ατόμων'
  ΔΙΑΒΑΣΕ ν
  ΓΡΑΨΕ 'Η θέση του επιζώντα είναι ', Α_Μ(2*(ν - 2^(Α_Μ(ΛΟΓ(ν)/ΛΟΓ(2)))) + 1) 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ JOSEPHUS
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Aireen

Νεοφερμένος

Η Aireen αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι 29 ετών και Μαθητής Γ' λυκείου . Έχει γράψει 14 μηνύματα.
Προσωπικα με πηρε αρκετη ωρα για να το λυσω...

Ενας Οργανισμος απαριθμεί 10000 μελη. Στις εκλογες για την αναδειξη του διοικητικου συμβουλιου υπαρχουν 15 υποψηφιοι και εκλεγονται πεντε. Καθε μελος του οργανισμου μπορει να ψηφισει μεχρι 3 υποψηφιους. Να γραφτει προγραμμα που θα υλοποιει τα παρακατω:

α) Θα καταχωρει σε πινακα ΨΗΦ[10000,3] τις ψηφους (η καταχωρηση γινεται απο χρηστη και οχι απο τους ιδιους τους ψηφοφορους) με τον εξης τροπο: θα βαζει εναν αριθμο απο το 1 μεχρι το 15 για καθε ψηφο στον αντιστοιχο υποψηφιο και αν το ψηφοδελτιο εχει εναν ή δυο μονο ψηφοφορους θα καταχωρειται το μηδεν στις υπολοιπες θεσεις της γραμμης του πινακα (δηλ. το ψηφοδελτιο που εχει ψηφους για τον 5ο και 11ο υποψηφιο θα καταχωρειται ως 5, 11, 0). Αν το ψηφοδελτιο εχει κριθει ακυρο ο χρηστης θα καταχωρει 0, 0, 0. Κατα την καταχωρηση πρεπει να γινεται ελεγχος ωστε να μην παιρνει ο ιδιος υποψηφιος περισσοτερες απο μια ψηφους σε κα8ε ψηφοδελτιο. Η λειτουργια ολων των ελεγχων στα δεδομενα που εισαγονται θα εκτελειται με την βοηθεια υποπρογραμματος.

β) Θα καταχωρει τα ονοματα των υποψηφιων σε πινακα ΥΠ[15].

γ) Θα υπολογιζει τις συνολικες ψηφους καθε υποφιου με τη βοη8εια υποπρογραμματος.

δ) Θα υπολογιζει το συνολο των ακυρων ψηφοδελτιων.

ε) Θα εμφανιζει τα ονοματα των υποψηφιων που εκλεγονται και τις ψηφους που ελαβαν.
Σε περιπτωση ισοψηφιας στη τελευταια θεση θα εμφανιζει λιστα με τα ονοματα των επιλαχοντων.
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

nikolas17

Πολύ δραστήριο μέλος

Ο Νίκος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Φοιτητής και μας γράφει απο Αθήνα (Αττική). Έχει γράψει 1,894 μηνύματα.
Τα 'Tab' δεν μου τα βγάζει =/ Στις σταθερές μέλη και κ βάλτε αντίστοιχα 10000 και 15.



ΠΡΟΓΡΑΜΜΑ Οργανισμός
ΣΤΑΘΕΡΕΣ
ΜΕΛΗ=10
Κ=10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ΨΗΦ[ΜΕΛΗ,3],Ι,J,ΑΠ[Κ],ΑΚΥΡΑ,Τ,Β[Κ],Γ,Μ
ΧΑΡΑΚΤΗΡΕΣ:ΥΠ[Κ]
ΛΟΓΙΚΕΣ:Α
ΑΡΧΗ
!ΕΙΣΑΓΩΓΗ ΨΗΦΩΝ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΕΛΗ
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΨΗΦ[Ι,J]
ΚΑΛΕΣΕ ΕΛΕΓΧΟΣ(ΨΗΦ,Α,Ι,J)
ΜΕΧΡΙΣ_ΟΤΟΥ Α=ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!ΕΙΣΑΓΩΓΗ ΟΝΟΜΑΤΩΝ ΥΠΟΨΗΦΙΩΝ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
ΔΙΑΒΑΣΕ ΥΠ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!ΥΠΟΛΟΓΙΣΜΟΣ ΣΥΝΟΛΙΚΩΝ ΨΗΦΩΝ & ΑΚΥΡΩΝ
ΚΑΛΕΣΕ ΥΠΟΛΟΓΙΣΜΟΣ(ΨΗΦ,ΑΠ,ΑΚΥΡΑ)
!ΕΥΡΕΣΗ ΥΠΟΨΗΦΙΩΝ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
Β[Ι] <-- Ι
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ
ΓΙΑ J ΑΠΟ Κ ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
ΑΝ ΑΠ[J-1]<ΑΠ[J] ΤΟΤΕ
Τ <-- ΑΠ[J-1]
ΑΠ[J-1] <-- ΑΠ[J]
ΑΠ[J] <-- Τ
Γ <-- Β[J-1]
Β[J-1] <-- Β[J]
Β[J] <-- Γ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 4
ΓΡΑΨΕ ΥΠ[Β[Ι]],ΑΠ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μ <-- ΑΠ[5]
Α <-- ΑΛΗΘΗΣ
ΓΙΑ Ι ΑΠΟ 6 ΜΕΧΡΙ Κ
ΑΝ ΑΠ[Ι]=Μ ΤΟΤΕ
ΓΡΑΨΕ ΥΠ[Β[Ι]],ΑΠ[Ι]
Α <-- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Α=ΑΛΗΘΗΣ ΤΟΤΕ
ΓΡΑΨΕ ΥΠ[Β[5]],ΑΠ[5]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!ΔΙΑΔΙΚΑΣΙΑ ΕΛΕΓΧΟΥ
ΔΙΑΔΙΚΑΣΙΑ ΕΛΕΓΧΟΣ(ΨΗΦ,Α,Ι,J)
ΣΤΑΘΕΡΕΣ
ΜΕΛΗ=10
Κ=10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ΨΗΦ[ΜΕΛΗ,3],Ι,J
ΛΟΓΙΚΕΣ:Α
ΑΡΧΗ
!ΕΛΕΓΧΟΣ ΓΙΑ ΑΚΥΡΑ (<>0)
ΑΝ ΨΗΦ[Ι,J]<>0 ΤΟΤΕ
!1ος ΨΗΦΟΣ
ΑΝ J=1 ΤΟΤΕ
Α <-- ΑΛΗΘΗΣ
!2ος ΨΗΦΟΣ
ΑΛΛΙΩΣ_ΑΝ J=2 ΤΟΤΕ
ΑΝ ΨΗΦ[Ι,1]<>ΨΗΦ[Ι,2] ΤΟΤΕ
Α <-- ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
Α <-- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
!3ος ΨΗΦΟΣ
ΑΛΛΙΩΣ_ΑΝ J=3 ΤΟΤΕ
ΑΝ ΨΗΦ[Ι,1]<>ΨΗΦ[Ι,3] ΚΑΙ ΨΗΦ[Ι,2]<>ΨΗΦ[Ι,3] ΤΟΤΕ
Α <-- ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
Α <-- ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
Α <-- ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛΟΓΙΣΜΟΥ ΨΗΦΩΝ & ΑΚΥΡΩΝ
ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛΟΓΙΣΜΟΣ(ΨΗΦ,ΑΠ,ΑΚΥΡΑ)
ΣΤΑΘΕΡΕΣ
ΜΕΛΗ=10
Κ=10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ΨΗΦ[ΜΕΛΗ,3],Ι,J,ΑΠ[Κ],ΜΕΤΡ,ΑΚΥΡΑ,Λ
ΑΡΧΗ
ΑΚΥΡΑ <-- 0
!ΜΗΔΕΝΙΣΜΟΣ ΨΗΦΩΝ ΚΑΘΕ ΥΠΟΨΗΦΙΟΥ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
ΑΠ[Ι] <-- 0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΕΛΗ
ΜΕΤΡ <-- 0
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
!ΕΛΕΓΧΟΣ ΓΙΑ ΑΚΥΡΑ
ΑΝ ΨΗΦ[Ι,J]=0 ΤΟΤΕ
ΜΕΤΡ <-- ΜΕΤΡ+1
ΤΕΛΟΣ_ΑΝ
!ΕΛΕΓΧΟΣ ΨΗΦΩΝ
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ Κ
ΑΝ ΨΗΦ[Ι,J]=Λ ΤΟΤΕ
ΑΠ[Λ] <-- ΑΠ[Λ]+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΜΕΤΡ=3 ΤΟΤΕ
ΑΚΥΡΑ <-- ΑΚΥΡΑ+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Aireen

Νεοφερμένος

Η Aireen αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι 29 ετών και Μαθητής Γ' λυκείου . Έχει γράψει 14 μηνύματα.
μια χαρα σε βρησκω!!!:no1:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 12 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

panos_anefs

Νεοφερμένος

Ο panos_anefs αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών και Απόφοιτος . Έχει γράψει 3 μηνύματα.
Καλησπέρα σας. Με λένε Παναγιώτη, φέτος έδωσα Πανελλαδικές, δεν έβγαλα τα επιθυμητά μόρια για προγραμματιστής υπολογιστών και θα ξαναδώσω του χρόνου. Η ΑΕΠΠ είναι το δυνατό μου μάθημα. Είναι το πρώτο μου post εδώ.
Βρήκα το forum με ένα search στο Google "ΑΕΠΠ ασκήσεις" καθώς ήθελα να φρεσκάρω λίγο τη μνήμη μου στο μάθημα, γιατί σε ένα μήνα ξαναρχίζω φροντηστήριο και έπεσα πάνω στο topic "Ασκήσεις ΑΕΠΠ για το 2008" όπου παρατήρησα πως υπήρχαν κάποια λάθη που δεν ανέφερε κανείς, αλλά θεώρησα πως είναι μια πάρα πολύ καλή προσπάθεια για τους μαθητές στην ΑΕΠΠ.
Θα ήθελα λοιπόν και εγώ να παραθέσω άσκηση προς λύση, είναι αρκετά δύσκολη για να πέσει ποτέ στις Πανελλήνιες αλλά αρκετά καλή για να τεστάρει το μυαλό σας.
-Να γράψετε πρόγραμμα το οποίο διαβάζει έναν αριθμό (ακέραιο) και εκτυπώνει τον αριθμό με τα ψηφία του σε αντίστροφη σειρά (π.χ 261 -> 162), (ο αριθμός δεν έχει απαραίτητα 3 ψηφία, και δεν υπάρχει όριο).
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Μιχάλης9867

Πολύ δραστήριο μέλος

Ο Μιχάλης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών , Φοιτητής και μας γράφει απο Νάξος (Κυκλάδες). Έχει γράψει 895 μηνύματα.
εγω σαν ακομα πιο δυσκολη θα προτεινα την εξης!


να βρεθει αριθμος αναμεσα στο 1000 και το 10000 ο οποιος πολαπλασιαζομενος με το 4 να δινει τον αριθμο που αποτελειται απο τα ψηφια του σε αντιστροφη σειρα!


χμ,δυσκολη ειπα?ευκολη ειναι και αρκετα ενδιαφερουσα!
-----------------------------------------
Καλησπέρα σας. Με λένε Παναγιώτη, φέτος έδωσα Πανελλαδικές, δεν έβγαλα τα επιθυμητά μόρια για προγραμματιστής υπολογιστών και θα ξαναδώσω του χρόνου. Η ΑΕΠΠ είναι το δυνατό μου μάθημα. Είναι το πρώτο μου post εδώ.
Βρήκα το forum με ένα search στο Google "ΑΕΠΠ ασκήσεις" καθώς ήθελα να φρεσκάρω λίγο τη μνήμη μου στο μάθημα, γιατί σε ένα μήνα ξαναρχίζω φροντηστήριο και έπεσα πάνω στο topic "Ασκήσεις ΑΕΠΠ για το 2008" όπου παρατήρησα πως υπήρχαν κάποια λάθη που δεν ανέφερε κανείς, αλλά θεώρησα πως είναι μια πάρα πολύ καλή προσπάθεια για τους μαθητές στην ΑΕΠΠ.
Θα ήθελα λοιπόν και εγώ να παραθέσω άσκηση προς λύση, είναι αρκετά δύσκολη για να πέσει ποτέ στις Πανελλήνιες αλλά αρκετά καλή για να τεστάρει το μυαλό σας.
-Να γράψετε πρόγραμμα το οποίο διαβάζει έναν αριθμό (ακέραιο) και εκτυπώνει τον αριθμό με τα ψηφία του σε αντίστροφη σειρά (π.χ 261 -> 162), (ο αριθμός δεν έχει απαραίτητα 3 ψηφία, και δεν υπάρχει όριο).


οποτε παει η χρηση πινακων?


με το ντιβ και το μοντ νομιζω βγαινει αλλα μπορει να κανω και λαθος,την εχω λυσει παντως
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

panos_anefs

Νεοφερμένος

Ο panos_anefs αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών και Απόφοιτος . Έχει γράψει 3 μηνύματα.
Oh finally, κάποιος απάντησε :P
Ναι, με div και mod βγαίνει, θέλετε να βάλω τη λύση; ^_^
Έλα μωρέ συμμετέχετε κι άλλοιιιιιιιι :bravo:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Μιχάλης9867

Πολύ δραστήριο μέλος

Ο Μιχάλης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών , Φοιτητής και μας γράφει απο Νάξος (Κυκλάδες). Έχει γράψει 895 μηνύματα.
καλη ασκηση...αλλα το μονο μου προβλημα ειναι οτι χρησιμοποιουμε στην αεππ στατικες δομες δεδομενων...:lol:

αυτη θα μπορουσε να γινει με ολισθηση?(βεβαια αναφερεται μονο σαν θεωρια στο βιβλιο:jumpy:)


χρησιμοποιεις καθολου ΓΛΩΣΣΟΜΑΘΕΙΑ?
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

panos_anefs

Νεοφερμένος

Ο panos_anefs αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών και Απόφοιτος . Έχει γράψει 3 μηνύματα.
Τίποτα απ'όλα αυτά, η άσκηση λύνεται πολύ απλά!
Ναι αμέ, χρησιμοποιώ γλωσσομάθεια!
by the way αυτό που έγραψες που το πολλαπλασιάζουμε με 4 και ειναι ο αντίστροφος κλπ, το είχα δει σε ένα περιοδικό με παιδικούς γρίφους, αλλά είναι βαρετό να κάνεις τέτοιο αλγόριθμο ;p Ιδού η λύση!

ΠΡΟΓΡΑΜΜΑ ΑΝΤΙΣΤΡΟΦΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι, ΜΙΧ, ΑΡ, Λ, S
ΑΡΧΗ
ΔΙΑΒΑΣΕ ΑΡ
ΜΙΧ<- ΑΡ
Λ<- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΜΙΧ<- ΜΙΧ DIV 10
Λ<- Λ+1
ΜΕΧΡΙΣ_ΟΤΟΥ ΜΙΧ=0
S<-0
ΑΝ Λ=1 ΤΟΤΕ
ΓΡΑΨΕ ΑΡ
ΑΛΛΙΩΣ
ΑΝ Ι=1 ΤΟΤΕ
S<- S+ΑΡ
ΑΛΛΙΩΣ
ΓΙΑ I ΑΠΟ Λ ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1
S<- S+(ΑΡ MOD 10)*(10^(Ι-1))
ΑΡ<- ΑΡ DIV 10
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ S
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Τρέξτε το, δουλεύει ^_^
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Μιχάλης9867

Πολύ δραστήριο μέλος

Ο Μιχάλης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών , Φοιτητής και μας γράφει απο Νάξος (Κυκλάδες). Έχει γράψει 895 μηνύματα.
εναλλακτικους τροπους για την λυση της ψαχνω!;)


οσο για το προγραμματακι που λεω ειναι ευκολακι:xixi:

αλλα η λυση του εχει ενδιαφερον διοτι απαιτει καλη γνωση της χρησης πινακων + του ντιβ και του μοντ
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Μιχάλης9867

Πολύ δραστήριο μέλος

Ο Μιχάλης αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 29 ετών , Φοιτητής και μας γράφει απο Νάξος (Κυκλάδες). Έχει γράψει 895 μηνύματα.
εγω τα διαβαζα ως εξης 1,2,3,4,7,8,9,10,6,ουσιαστικα μονο το εξη που ειναι μεγαλο αφησα τελευταιο (κατα σειρα παντα) αλλα αυτο που εκανα εγω και με βοηθησε πολυ ηταν να μαθαινω επιλεκτικα την θεωρια,δηλαδη μου ειχε υπογραμμισει η καθηγητρια τι πρεπει να ξερωκαι τα μαθαινα,ετσι υπαρχουν αρκετες σελιδες που δεν τους εχω ριξει ουτε μια ματια,αλλα γενικα και παλι η συνολικη θεωρια εφτανε γυρω στις 50 σελιδες...
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Ntzios Kostas

Νεοφερμένος

Ο Ntzios Kostas αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 47 ετών και Καθηγητής . Έχει γράψει 56 μηνύματα.
Φίλε Μιχάλη,

Σου προτείνω το διάβασμα των κεφαλαίων (δεν εννοώ μόνο θεωρία), να γίνει όπως προτείνει και το βιβλίο του καθηγητή, αλλά και του μαθητή. Δηλαδή, διαβάζεις

  • αρχικά το 1ο
  • μετά το 2ο μαζί με το 7 και το 8
  • μετά το 9ο μαζί 3ο (αλλά ξεκίνα καλύτερα με το 9ο)
  • μετά το 6ο
  • και τέλος το 10ο
Με εκτίμηση,

Ντζιός Κώστας
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Black_Butterfly

Πολύ δραστήριο μέλος

Η Αλεξάνδρα αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι Φοιτητής και μας γράφει απο Ηράκλειο (Κρήτη). Έχει γράψει 1,327 μηνύματα.
Καλησπέρα σας,
Μήπως γνωρίζετε sites ή έχετε κανα pdf με μέτριες και δύσκολες ασκήσεις για τον Προγραμματισμό;
Επίσης και αν έχετε ασκήσεις Σωστού-λαθους, αντιστοίχισης και προγράμματα/αλγόριθμους που ζητάνε πίνακες τιμών δεκτές. :D
Merci! :xixi:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

ptsiotakis

Εκκολαπτόμενο μέλος

Ο ptsiotakis αυτή τη στιγμή δεν είναι συνδεδεμένος. Έχει γράψει 271 μηνύματα.

Black_Butterfly

Πολύ δραστήριο μέλος

Η Αλεξάνδρα αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι Φοιτητής και μας γράφει απο Ηράκλειο (Κρήτη). Έχει γράψει 1,327 μηνύματα.
Ευχαριστώ πολύ! :xixi:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 11 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Χρήστες Βρείτε παρόμοια

  • Τα παρακάτω 0 μέλη και 1 επισκέπτες διαβάζουν μαζί με εσάς αυτό το θέμα:
    Tα παρακάτω 5 μέλη διάβασαν αυτό το θέμα:
  • Φορτώνει...
Top