[2007 - 2008] Ασκήσεις στην ΑΕΠΠ

Status
Το θέμα δεν είναι ανοιχτό για νέες απαντήσεις.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Στο παρόν θα γράφουμε ασκήσεις πάνω στην ΑΕΠΠ και λύσεις τους για το έτος 2007-2008.

Και ξεκινώ δίνοντας δύο προς επίλυση (μόλις τις έβγαλα, φρέσκες φρέσκες :D)

Η πρώτη είναι μέχρι και δομή επιλογής.
Η δεύτερη (αρκετά τσιμπημένη) μέχρι και δομή επανάληψης και καλή γνώση της θεωρίας (πρόγραμμα & αλγόριθμος μέχρι τα αντίστοιχα σημεία).


Άσκηση 1

Να γραφεί πρόγραμμα στο οποίο ο χρήστης θα δίνει δύο ονόματα και θα εμφανίζεται αυτό που προηγείται αλφαβητικά. Αν για παράδειγμα ο χρήστης δίνει "Κώστας" και "Βασίλης" θα εμφανίζει:

Code:
Αλφαβητικά προηγείται ο Βασίλης κι έπεται ο Κώστας.
Από Γιώργος

Άσκηση 2


Να γραφεί πρόγραμμα στο οποίο ο χρήστης θα δίνει επαναλαμβανόμενα σειρές χαρακτήρων. Το πρόγραμμα θα υπολογίζει και θα εμφανίζει τον αριθμό των λέξεων που αρχίζουν από 'Κ'. Από αυτές τις λέξεις, θα εμφανίζει τη λέξη που προηγείται αλφαβητικά. Το πρόγραμμα θα ρωτάει κάθε φορά τον χρήστη εάν επιθυμεί να συνεχίσει και θα σταματάει όταν δοθεί η λέξη "όχι". Θεωρείστε ότι δίνονται από τον χρήστη μόνο πεζοί χαρακτήρες.

Από Γιώργος




Ανεβάστε τις να τις δούμε. :)
Σημείωση: ο συντάκτης πρέπει να γνωρίζει τη λύση των ασκήσεων. Αν έχετε άσκηση στην οποίες θέλετε τη λύση τους, ανοίξτε χωριστό thread.
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Επεξεργάστηκε από συντονιστή:

Vorbulon

Νεοφερμένος

Ο Vorbulon αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 30 ετών και Απόφοιτος . Έχει γράψει 102 μηνύματα.
Για την άσκηση 2: (δεν μου εμφανίζει τα κενά στην αρχή της σειράς)
Code:
ΠΡΟΓΡΑΜΜΑ Λέξεις
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλ
  ΧΑΡΑΚΤΗΡΕΣ: λέξη, αλφ, συ
ΑΡΧΗ
  πλ <- 0
  αλφ <- 'λ'
  συ <- 'ο'
  ΓΡΑΨΕ 'Δώστε λέξεις'
  ΟΣΟ συ <> 'όχι' ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ λέξη
    ΑΝ λέξη >= 'κ' ΚΑΙ λέξη < 'λ' ΤΟΤΕ
      πλ <- πλ+1
      ΑΝ λέξη < αλφ ΤΟΤΕ
        αλφ <- λέξη
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Επιθυμείτε να συνεχίσετε;'
    ΔΙΑΒΑΣΕ συ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ πλ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν δόθηκαν λέξεις που να αρχίζουν από κ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Από κ αρχίζουν ', πλ, ' λέξεις και αυτή που προηγείται αλφαβητικά είναι η ',   αλφ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Με μία γρήγορη ματιά φαίνεσαι σωστός. ;)
Ωστόσο εγώ θα διάβαζα το "Αν θέλει να συνεχίσει" σε άλλη μεταβλητή και θα χρησιμοποιούσα "ΜΕΧΡΙΣ_ΟΤΟΥ" εντολή.

Btw για να σου βγάζει τα κενά χρησιμοποίησε τα CODE tags, δηλ. >>
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Vorbulon

Νεοφερμένος

Ο Vorbulon αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 30 ετών και Απόφοιτος . Έχει γράψει 102 μηνύματα.
Έχεις δίκιο. Και εγώ ΜΕΧΡΙΣ_ΟΤΟΥ θα έβαζα κανονικά, απλά είχα διαβάσει λάθος στη αρχή την άσκηση (νόμιζα ότι με τη λέξη όχι τελειώνει το πρόγραμμα, δηλαδή αν η μεταβλητή λέξη έπαιρνε την τιμή όχι) και βιαζόμουν να φύγω για το σχολείο (δες την ώρα :)). Πρωί πρωί το θέλεις το σερφάρισμα!!!
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

mostel

Πολύ δραστήριο μέλος

Ο Στέλιος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών , Φοιτητής και μας γράφει απο Θεσσαλονίκη (Θεσσαλονίκη). Έχει γράψει 1,203 μηνύματα.
Μια δική μου.. εύκολη σχετικά.

Άσκηση 3

Να γίνει αλγόριθμος που θα διαβάζει τα ονόματα, τον μισθό, τον ΑΜ των υπαλλήλων μιας εταιρίας και να υπολογίζει τον Μ.Ο. αυτών που παίρνουν πάνω από 1000 ευρώ. Επίσης, να εμφανίζει αυτόν που παίρνει τον μικρότερο μισθό και αυτόν που παίρνει το μεγαλύτερο. Ο αλγόριθμος θα τερματίζει όταν δοθεί το όνομα "Κομπιουτερίδης", χωρίς να εκτέλεστουν οι υπόλοιπες διαδικασίες (χωρίς να ζητηθεί από το χρήστη δηλαδή ο μισθός του Κομπιουτερίδη κ.λπ.)
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Scandal

Διαχειριστής

Ο Πέτρος αυτή τη στιγμή είναι συνδεδεμένος. Είναι 32 ετών , Φοιτητής του τμήματος Πληροφορικής Ο.Π.Α. (Αθήνα) και μας γράφει απο Περιστέρι (Αττική). Έχει γράψει 11,362 μηνύματα.
Άσκηση 3

Να γίνει αλγόριθμος που θα διαβάζει τα ονόματα, τον μισθό, τον ΑΜ των υπαλλήλων μιας εταιρίας και να υπολογίζει τον Μ.Ο. αυτών που παίρνουν πάνω από 1000 ευρώ. Επίσης, να εμφανίζει αυτόν που παίρνει τον μικρότερο μισθό και αυτόν που παίρνει το μεγαλύτερο. Ο αλγόριθμος θα τερματίζει όταν δοθεί το όνομα "Κομπιουτερίδης", χωρίς να εκτέλεστουν οι υπόλοιπες διαδικασίες (χωρίς να ζητηθεί από το χρήστη δηλαδή ο μισθός του Κομπιουτερίδη κ.λπ.)

Code:
Αλγόριθμος Άσκηση3
Δεδομένα // όνομα,μισθός,ΑΜ,ΜΟ,όνομαMin,όνομαMax,Α //
μισθός <-- 0
ΑΜ <-- 0
ΜΟ <-- 0

  Εμφάνισε "Δώστε το όνομα του υπαλλήλου"
  Διάβασε όνομα
  Εμφάνισε "Δώστε το μισθό του υπαλλήλου", όνομα
  Διάβασε μισθός
  Εμφάνισε "Δώστε τον ΑΜ του υπαλλήλου", όνομα
  Διάβασε ΑΜ
min <-- 1000000000000000000000000
max <-- 0

Όσο όνομα ≠ Κομπιουτερίδης επανάλαβε

    Σ <-- 0
    Α <-- 0
  Αν μισθός > 1000 τότε
    Σ <-- Σ + μισθός
    Α <-- Α+1
  τέλος_αν

  Αν μισθός < min τότε
   min <-- μισθός
  όνομαMin <-- όνομα
  τέλος_αν

  Αν μισθός > max τότε
   max <-- μισθός
  όνομαMax <-- όνομα
  τέλος_αν

  Εμφάνισε "Δώστε το όνομα του επόμενου υπαλλήλου"
  Διάβασε όνομα
  Εμφάνισε "Δώστε το μισθό του υπαλλήλου", όνομα
  Διάβασε μισθός
  Εμφάνισε "Δώστε τον ΑΜ του υπαλλήλου", όνομα
  Διάβασε ΑΜ

τέλος_επανάληψης

ΜΟ <-- ΜΟ/Α
Εμφάνισε "Ο Μ.Ο των υπαλλήλων που παίρνουν πάνω από 1000 ευρώ είναι", ΜΟ "."
Εμφάνισε "Μεγαλύτερο μισθό παίρνει ο/η", όνομαMax "."
Εμφάνισε "Μικρότερο μισθό παίρνει ο/η", όνομαMin "."

Τέλος Άσκηση3

Ελπίζω να είναι ok γιατί έχω να λύσω άσκηση στην ανάπτυξη εφαρμογών από τις πανελλαδικές. :'(:P


-petros
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Να 'σαι καλά ρε Πέτρο, κάτι που ήθελα να τονίσω. ;)

Ας πάμε πρώτα στα βασικά, το "Δεδομένα // όνομα,μισθός,ΑΜ,ΜΟ,όνομαMin,όνομαMax,Α //" δεν χρειάζεται. Αυτό χρειάζεται αν έχουμε κάποια σταθερά επί παραδείγματι.


Πάμε και στο ζουμί.

Δεν δίνω δεκάρα τι λένε τα φροντηστήρια ή τα βοηθήματα, αλλά ποτέ ποτέ δεν αρχικοποιούμε min σε κάτι "πολύ μεγάλο" (κι αντίστοιχα το max σε κάτι "πολύ μικρό").

Πώς το κάνουμε; Ορίζουμε min=max=το πρώτο-πρώτο μέγεθος που θα διαβαστεί. Θεωρούμε δηλαδή ότι το πρώτο μέγεθος θα είναι και το min και το max.
Πώς θα "καταλάβει" ο υπολογιστής ότι διαβάζουμε το πρώτο μέγεθος;

Ένας τρόπος είναι ορίζοντας μεταβλητή πλήθους και η συνθήκη είναι: Αν Πλήθος_Μετρήσεων = 1
Ή i=1, αν τα διαβάζεις με ΓΙΑ.
Προσοχή, το πλήθος που χρησιμοποιείς στο πρόγραμμα, είναι άλλο πλήθος, όχι το πλήθος μετρήσεων.

Άλλος τρόπος; Εδώ, επειδή ξέρουμε ότι μισθός>0, ορίζουμε min=max=0. Και η συνθήκη είναι min=0 (ή max=0, ισοδύναμα).


Έπειτα, θα δεις ότι έχω βάλει συνθήκη Αν μισθός > 0. Το πρόγραμμα δεν ζητά έλεγχο δεδομένων και πολύ σωστά δεν έβαλες. Όμως τι είναι έλεγχος δεδομένων; Απλά βάζεις την μεταβλητή σου με μία ΜΕΧΡΙΣ_ΟΤΟΥ και του ζητάς σε λάθος εισαγωγή να δώσει σωστό δεδομένο.
Εδώ τι παίζει;

Ο μισθός είναι θετικός αριθμός (κανείς δεν δουλεύει και πληρώνει κι από πάνω - λέμε - και φυσικά κανείς δεν δουλεύει αμισθοί).
Εφόσον δεν ζητάει έλεγχο δεδομένων, δεν κάνεις έλεγχο.

Ωστόσο, δεν σου ξεκαθαρίζει κι όλας ότι θα δίνονται θετικοί.
Αν δοθεί μη θετικός... τότε απλά το πρόγραμμά μας δεν κάνει τίποτα και διαβάζει τον επόμενο. ;)

Και τέλος... Πέτρο παιδί μου, διαιρείς με μηδέν; :P


Code:
[B]Αλγόριθμος [/B]Άσκηση3
 [COLOR=Navy][I] μισθός ← 0
  ΑΜ ← 0
  ΜΟ ← 0[/I][/COLOR]  [B][COLOR=DarkGreen]!Περιττά, ωστόσο δεν κόβεται κάτι[/COLOR][/B]
  min ← 0
  max ← 0   [B][COLOR=DarkGreen]!Το min=max=0 δηλώνει ότι δεν έχουν διαβαστεί ακόμα μισθοί[/COLOR][/B]
  Σ ← 0
  Α ← 0 [B][COLOR=DarkGreen]!Τα αρχικοποιούμε μία φορά εκτός επανάληψης!!!! Όχι συνέχεια εντός της επανάληψης. Έτσι το Α θα ισούται στο τέλος με 1, πάντα.[/COLOR][/B]

  [B]Εμφάνισε [/B]"Δώστε το όνομα του υπαλλήλου "
[B]  Διάβασε [/B]όνομα

[B][COLOR=DarkGreen]  !Αν δοθεί το "Κομπιουτερίδης στην αρχή??? Φεύγουν τα υπόλοιπα[/COLOR][/B]

  [B]Όσο [/B]όνομα ≠ Κομπιουτερίδης επανάλαβε   [B][COLOR=DarkGreen]!Όχι <> αλλά ≠, εφόσον είναι αλγόριθμος (σωστά το 'κανες)
[/COLOR][/B]   [B] Εμφάνισε [/B]"Δώστε το μισθό του υπαλλήλου ", όνομα
[B]    Διάβασε [/B]μισθός

    [B]Αν [/B]μισθός > 0 [B]τότε   [/B][B][COLOR=DarkGreen]!Αν δοθεί μη θετικός; Απλά δεν κάνουμε τίποτα.[/COLOR][/B]
[B]      Εμφάνισε [/B]"Δώστε τον ΑΜ του υπαλλήλου", όνομα
[B]      Διάβασε [/B]ΑΜ
[B]
      Αν [/B]min = 0 [B]τότε
[/B]        min ← μισθός
        max ← μισθός[B]
      Τέλος_αν[/B]

     [B] Αν [/B]μισθός > 1000 [B]τότε   [COLOR=DarkGreen]!Δεν είναι λάθος, αλλά προσοχή στις εσοχές[/COLOR][/B]
        Σ ← Σ + μισθός
        Α ← Α+1
      [B]Τέλος_αν[/B]     [B][COLOR=DarkGreen]!"Τέλος_αν" κι όχι "τέλος_αν"[/COLOR][/B]

[B]      Αν [/B]μισθός < min [B]τότε[/B]
        min ← μισθός
        όνομαMin ← όνομα
      [B]Τέλος_αν[/B]

[B]      Αν [/B]μισθός > max [B]τότε[/B]
        max ← μισθός
        όνομαMax ← όνομα
      [B]Τέλος_αν
    Τέλος_αν
[/B] 
   [B] Εμφάνισε [/B]"Δώστε το όνομα του επόμενου υπαλλήλου"   [B][COLOR=DarkGreen]!Again, προσοχή στις εσοχές. Δεν κόβει, αλλά βοηθάει.[/COLOR][/B]
    [B]Διάβασε [/B]όνομα
    [B][COLOR=DarkGreen]!Όπως κι εδώ, αν δοθεί το κομπιουτερίδης τα άλλα διαβάζονται, οπότε πάλι κόβει. Άρα δεν διαβάζει μισθό και ΑΜ[/COLOR][/B]
  [B]Τέλος_επανάληψης[/B]   [B][COLOR=DarkGreen]!"Τέλος_επανάληψης", όχι "τέλος_επανάληψης"[/COLOR][/B]


  [B]Αν [/B]Α≠0 [B]τότε   [COLOR=DarkGreen]!Αν διαιρέσουμε με το 0??? Τσεκούρι πέφτει εδώ!![/COLOR][/B]
    ΜΟ ← Σ/Α   [B][COLOR=DarkGreen]!Σ/Α. όχι ΜΟ/Α, βρε.[/COLOR][/B]
   [B] Εμφάνισε [/B]"Ο Μ.Ο των υπαλλήλων που παίρνουν πάνω από 1000 ευρώ είναι", ΜΟ "."
  [B]αλλιώς[/B]
    [B]Εμφάνισε [/B]"Δεν υπάρχουν υπάλληλοι με μισθό πάνω από 1000 ευρώ."
 [B] Τέλος_αν
  [/B][B]Αν [/B]min>0 [B]τότε   [/B][B][COLOR=DarkGreen]!Αν δηλαδή υπάρχουν έγκυροι μισθοί[/COLOR][/B]
   [B] Εμφάνισε [/B]"Μεγαλύτερο μισθό παίρνει ο/η", όνομαMax[highlight],[/highlight] "."   [B][COLOR=DarkGreen]!Ξέχασες το ',' που σου έχω κάνει highlight. Είναι βασικό[/COLOR][/B]
   [B] Εμφάνισε [/B]"Μικρότερο μισθό παίρνει ο/η", όνομαMin[highlight],[/highlight] "."
 [B] Τέλος_αν[/B]

[B]Τέλος [/B]Άσκηση3
Σε ΠΡΟΓΡΑΜΜΑ. :)

Άλλαξα το 'Α' σε 'Πλήθος', καθώς είναι καλό να έχουν οι μεταβλητές μας προφανή ονόματα.
Δείτε επίσης πόσο ξεκούραστο είναι ένα πρόγραμμα χωρίς σχόλια και με τις κατάλληλες εσοχές. Σωστός επίσης ο Πέτρος που άφησε κενές γραμμές μεταξύ των διαφόρων τμημάτων του προγράμματός του.

Επίσης το 1000 το όρισα σταθερά. Δεν είναι υποχρεωτικό, αλλά είναι καλό ως προγραμματιστική τεχνική (να βάζουμε τα σημαντικά νούμερά μας ως σταθερές) και προδιαθέτει θετικά τον διορθωτή. :iagree:

Επίσης το "Πλήθος" το ορίζω ως τύπου Πραγματικός μιας και θα χρησιμοποιηθεί σε διαίρεση '/'. (Κι άλλωστε δεν πειράζει κανέναν, εφόσον εγώ την ελέγχω.)
Code:
[B]ΠΡΟΓΡΑΜΜΑ [/B]Άσκηση3

[B]ΣΤΑΘΕΡΕΣ[/B]
  ΟΡΙΟ = 1000

[B]ΜΕΤΑΒΛΗΤΕΣ

[/B]  [B]ΠΡΑΓΜΑΤΙΚΕΣ:[/B] μισθός, Πλήθος, ΜΟ, SUM, min, max
  [B]ΑΚΕΡΑΙΕΣ:[/B] ΑΜ
  [B]ΧΑΡΑΚΤΗΡΕΣ:[/B] όνομα, όνομαMin, όνομαMax

[B]ΑΡΧΗ[/B]
  SUM ← 0
  min ← 0
  max ← 0
  Πλήθος ← 0

  [B]ΓΡΑΨΕ[/B] 'Δώστε το όνομα του υπαλλήλου : '
[B]  ΔΙΑΒΑΣΕ [/B]όνομα

  [B]ΟΣΟ [/B]όνομα <> Κομπιουτερίδης επανάλαβε   
    [B]ΓΡΑΨΕ [/B]'Δώστε το μισθό του υπαλλήλου : ', όνομα
[B]    ΔΙΑΒΑΣΕ [/B]μισθός

    [B]ΑΝ [/B]μισθός > 0 [B]ΤΟΤΕ
[/B][B]      ΓΡΑΨΕ [/B]'Δώστε τον ΑΜ του υπαλλήλου ', όνομα
[B]      ΔΙΑΒΑΣΕ [/B]ΑΜ

 [B]     ΑΝ [/B]min = 0 [B]ΤΟΤΕ
[/B]        min ← μισθός
        max ← μισθός
[B]      ΤΕΛΟΣ_ΑΝ[/B]

      [B]ΑΝ [/B]μισθός > ΟΡΙΟ [B]ΤΟΤΕ[/B]
        SUM  ← SUM  + μισθός
        Πλήθος ← Πλήθος + 1
      [B]ΤΕΛΟΣ_ΑΝ

[/B][B]      ΑΝ [/B]μισθός < min [B]ΤΟΤΕ[/B]
        min ← μισθός
        όνομαMin ← όνομα
      [B]ΤΕΛΟΣ_ΑΝ[/B]
[B]      ΑΝ [/B]μισθός > max [B]ΤΟΤΕ[/B]
        max ← μισθός
        όνομαMax ← όνομα
      [B]ΤΕΛΟΣ_ΑΝ[/B]
    [B]ΤΕΛΟΣ_ΑΝ[/B]
 
    [B]ΓΡΑΨΕ [/B]'Δώστε το όνομα του επόμενου υπαλλήλου : '
    [B]ΔΙΑΒΑΣΕ [/B]όνομα
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΑΝ [/B]Πλήθος<>0 [B]ΤΟΤΕ[/B]
    ΜΟ ← SUM/Πλήθος
    [B]ΓΡΑΨΕ [/B]'Ο Μ.Ο των υπαλλήλων που παίρνουν πάνω από 1000 ευρώ είναι', ΜΟ, '.'
  [B]ΑΛΛΙΩΣ[/B]
    [B]ΓΡΑΨΕ '[/B]Δεν υπάρχουν υπάλληλοι με μισθό πάνω από 1000 ευρώ.'
 [B] ΤΕΛΟΣ_ΑΝ
  [/B][B]ΑΝ [/B]min>0 [B]ΤΟΤΕ[/B]
    [B]ΓΡΑΨΕ [/B]'Μεγαλύτερο μισθό παίρνει ο/η', όνομαMax, '.'
    [B]ΓΡΑΨΕ [/B]'Μικρότερο μισθό παίρνει ο/η', όνομαMin, '.'
 [B] ΤΕΛΟΣ_ΑΝ[/B]

[B]ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ[/B]
Είδατε πάντως πόσο χρήσιμα βγήκαν από ένα πρόγραμμα. Στέλντε λύσεις, κι αν είναι και (κατά τη γνώμη σας) λάθος. Έτσι μαθαίνουμε. ;) :no1:



Υ.γ.: Ουφ.. κουραστικό να γράφεις τόσο μεγάλο κώδικα σε υπολογιστή, αλλά 20 φορές πιο κουραστικό να το γράφεις στο χέρι. :P

Μην σας τρομάζουν επίσης οι μεγάλοι κώδικες. Θα συναντήσετε μπόλικα τέτοια.



Από Γιώργος
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Scandal

Διαχειριστής

Ο Πέτρος αυτή τη στιγμή είναι συνδεδεμένος. Είναι 32 ετών , Φοιτητής του τμήματος Πληροφορικής Ο.Π.Α. (Αθήνα) και μας γράφει απο Περιστέρι (Αττική). Έχει γράψει 11,362 μηνύματα.
Δεν δίνω δεκάρα τι λένε τα φροντηστήρια ή τα βοηθήματα, αλλά ποτέ ποτέ δεν αρχικοποιούμε min σε κάτι "πολύ μεγάλο" (κι αντίστοιχα το max σε κάτι "πολύ μικρό").

!Όχι <> αλλά ≠, εφόσον είναι αλγόριθμος (σωστά το 'κανες)
1. εχμμ εντάξει, και αυτοί που κάνουν στα φροντιστήρια καθηγητές είναι (και η καθηγήτρια στο σχολείο απ' ότι θυμάμαι μας το είχε πει αυτό για "μια μεγάλη τιμή στο min και μια μικρή στο max". Το ίδιο και αυτοί που τα διορθώνουν. :)

2. Αυτό με τα ≠ επειδή είναι αλγόριθμος και το <> για πρόγραμμα δε τα ήξερα. :emm:
Βασικά πάντα <> έβαζα αλλά έχω σκουριάσει τόσο που το ξέχασα και έβαλα το συνηθισμένο σύμβολο ≠ :D

3. α). Την άσκηση την έλυσα εντός λίγων λεπτών και:
β). Δεν είναι το ίδιο να τα γράφεις σε χαρτί με το να τα γράφεις με το πληκτρολόγιο
γ). Έχω καιρό να εξασκηθώ.
[προσπαθώ να δικαιολογηθώ :P ]

Από τα Χριστούγεννα και μετά θα ασχοληθώ με αυτό το μάθημα.
Πάντως αν γράψω κάτω από 18 στις ερχόμενες πανελλαδικές στην ΑΕΠΠ θα με χάσετε από admin και προσώπου γης. :'(:'(


-petros
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

mostel

Πολύ δραστήριο μέλος

Ο Στέλιος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών , Φοιτητής και μας γράφει απο Θεσσαλονίκη (Θεσσαλονίκη). Έχει γράψει 1,203 μηνύματα.
Πολύ ωραίες οι λύσεις...

Αρχικά και 'γω ήθελα να τονίσω μέσα από την άσκηση ότι στον αλγόριθμο ΔΕΝ βάζουμε <>

Επίσης, έγινε και κουβέντα για τα max, min. Είχα σκοπό να τα πω εγώ, αλλά με πρόλαβε ο Γιώργος, ο οποίος τα ανέλυσε όλα άψογα! :no1:

Πολύ καλή δουλειά και από τους δυο σας.

Α! Πέτρο, 20 θα γράψεις!! :)
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

rivaldo21

Νεοφερμένος

Ο rivaldo21 αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών και Μαθητής Γ' λυκείου . Έχει γράψει 12 μηνύματα.
Νά κι απο μένα μία άσκηση που μου άρεσε αρκετά!

Άσκηση 4

Μια εταιρεία κινητής τηλεφωνίας ακολουθεί ανα μήνα την εξής πολιτική τιμών:
Πάγιο: 5Ε
Χρόνος τηλεφωνημάτων σε (δευτερόλεπτα) Χρονοχρέωση (ε/δευτερόλεπτο)
1-500 _0,006Ε
501-800 _ 0,004Ε
801 και άνω _0,003Ε

Να αναπτυχθεί αλγόριθμος ο οποίος:
  1. να διαβάζει τη χρονική διάρκεια των τηλεφωνημάτων ενός συνδρομητή σε διάστημα ενός μηνα.
  2. να υπολογίζει τη μηνιαία χρέωση του συνδρομιτή
  3. να εμφανίζει τη λέξη "ΧΡΕΩΣΗ" και τη μηνιαία χρέωση του συνδρομιτή.
Ελπίζω να είναι κατανοητή!!!
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

lunatic

Νεοφερμένος

Η lunatic αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι 31 ετών και Απόφοιτος . Έχει γράψει 35 μηνύματα.
Αρχικά και 'γω ήθελα να τονίσω μέσα από την άσκηση ότι στον αλγόριθμο ΔΕΝ βάζουμε <>
δηλαδη αν το βαλουμε θα πιαστει για λαθος??γιατι στο φροντιστηριο το χρησιμοποιουμε και σε αλγοριθμο αλλα και σε προγραμμα:s
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

rivaldo21

Νεοφερμένος

Ο rivaldo21 αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών και Μαθητής Γ' λυκείου . Έχει γράψει 12 μηνύματα.
Θέλω να ρωτήσω κάτι άσχετο... ξεκίνησα τον προηγούμενο μήνα το φροντιστήριο αλλα την προηγούμενη άσκηση δεν ξέρω να την λύνω. Αυτήν που έβαλα την εκανα αμέσως. Έχω τελειώσει και τις συνθήκες στο φροντιστήριο μετά τί έπεται? (Για σχολείο μην ρωτήσετε για ξέρετε πως είανι στην επαρχία)! Είναι κάτι δύσκολο μετά?

δηλαδη αν το βαλουμε θα πιαστει για λαθος??γιατι στο φροντιστηριο το χρησιμοποιουμε και σε αλγοριθμο αλλα και σε προγραμμα:s
Κι εμείς σε σχολείο και φροντιστήριο το <> χρισημοποιούμαι αλλά με μια γρήγορη ματιά στο βιβλίο στην σελίδα 46 δέν αναφέρει τέτοιο σύμβολο στου Τελεστές!!!
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

lunatic

Νεοφερμένος

Η lunatic αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι 31 ετών και Απόφοιτος . Έχει γράψει 35 μηνύματα.
οντως!!αλλα και στο βιβλιο του φροντιστηριου που πηγαινω αναφερει ως διαφορετικο για αλγοριθμο το ≠
αλλα μαλλον ειναι στα ''ψιλα γραμματα'' γιατι κανενας δεν μας το εχει αναφερει ως τωρα.Αλλα οταν ξαναεχω αναπτυξη εφαρμογων στο φροντ. θα τους ρωτησω...
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Αλλα οταν ξαναεχω αναπτυξη εφαρμογων στο φροντ. θα τους ρωτησω...
Δεν πρόκειται να βγάλεις άκρη. Έχω έρθει σε πολλές αντιπαραθέσεις με φροντιστές και τελικά δεν έχει κανένα νόημα. :)


Αλγόριθμος: ≠
ΠΡΟΓΡΑΜΜΑ: <>



Στο λέω 100%. :no1:




Κι επίσης... δεν με νοιάζει τι λέει το κάθε φροντηστηριακό βιβλίο παρά μόνο το σχολικό. Ξεκολλήστε από τα φροντηστιριακά βιβλία αναφορικά με θεωρία. Σχεδόν όλα έχουν ελλείψεις.-


Διαβάστε κεφάλαια 7-8-9-10 από βιβλίο, κάντε πάντα προγράμματα και πάτε προς ολοταχώς για βαθμό.
(Τα 7 έως 10 για τα προγράμματα. Τα 1-6 απαραίτητα για τη θεωρία.)
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

mostel

Πολύ δραστήριο μέλος

Ο Στέλιος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών , Φοιτητής και μας γράφει απο Θεσσαλονίκη (Θεσσαλονίκη). Έχει γράψει 1,203 μηνύματα.
Λοιπόν, βάζω μια άσκηση που μόλις κατασκεύασα. Εδώ φαίνεται η σημασία του γράφω αλγόριθμο από μέσα προς τα έξω. Κατ' αυτόν τον τρόπο βγαίνει η άσκηση πολύ πιο εύκολα. Έχουμε λοιπόν:

Άσκηση 5

Μια επιχείρηση έχει 30 πωλητές. Να γίνει αλγόριθμος που θα διαβάζει τις πωλήσεις για κάθε πωλητή. Στη συνέχεια θα υπολογίζει και θα εμφανίζει το άθροισμα των πωλήσεων για κάθε μήνα και για κάθε τρίμηνο του κάθε πωλητή. Επίσης, θα εμφανίζει το bonus που θα λάβει ο κάθε πωλητής, γνωριζόντας ότι αν ο τριμηνιαίος τζίρος (του κάθε πωλητή) ξεπεράσει τα 30.000 ευρώ, τότε ο πωλητής δικαιούται το 5% των κερδών. Τέλος, θα εμφανίζει το σύνολο των χρημάτων που θα εισπράξει η εταιρία από όλους τους πωλητές, αλλά και θα εμφανίζει το σύνολο των χρημάτων που θα δώσει η εταιρία από τα κέρδη στους πωλητές, εξαιτίας των bonus. Αν τα καθαρά κέρδη της επιχείρησης είναι πάνω από 400.000 ευρώ, θα εμφανίζεται το μήνυμα "Η επιχείρηση έχει κέρδη", αλλιώς το μήνυμα "Η επιχείρηση έχει ζημία".

 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Λοιπόν, βάζω μια άσκηση που μόλις κατασκεύασα. Εδώ φαίνεται η σημασία του γράφω αλγόριθμο από μέσα προς τα έξω. Κατ' αυτόν τον τρόπο βγαίνει η άσκηση πολύ πιο εύκολα. Έχουμε λοιπόν:

Άσκηση 5

Μια επιχείρηση έχει 30 πωλητές. Να γίνει αλγόριθμος που θα διαβάζει τις πωλήσεις για κάθε πωλητή. Στη συνέχεια θα υπολογίζει και θα εμφανίζει το άθροισμα των πωλήσεων για κάθε μήνα και για κάθε τρίμηνο του κάθε πωλητή. Επίσης, θα εμφανίζει το bonus που θα λάβει ο κάθε πωλητής, γνωριζόντας ότι αν ο τριμηνιαίος τζίρος (του κάθε πωλητή) ξεπεράσει τα 30.000 ευρώ, τότε ο πωλητής δικαιούται το 5% των κερδών. Τέλος, θα εμφανίζει το σύνολο των χρημάτων που θα εισπράξει η εταιρία από όλους τους πωλητές, αλλά και θα εμφανίζει το σύνολο των χρημάτων που θα δώσει η εταιρία από τα κέρδη στους πωλητές, εξαιτίας των bonus. Αν τα καθαρά κέρδη της επιχείρησης είναι πάνω από 400.000 ευρώ, θα εμφανίζεται το μήνυμα "Η επιχείρηση έχει κέρδη", αλλιώς το μήνυμα "Η επιχείρηση έχει ζημία".


Ενδιαφέρουσα. :D

(Μην δείτε το παρακάτω αν θέλετε να τη λύσετε :P)






Code:
[B]ΠΡΟΓΡΑΜΜΑ[/B] Η_καλή_μου_επιχείρηση

[B]ΣΤΑΘΕΡΕΣ[/B]
  EMPL = 30
  ΟΡΙΟ_BONUS = 30000
  TARGET = 400000
  BONUS_PERCENT = 0.05
  MSG1 = 'Η επιχείρηση έχει κέρδη'
  MSG2 = 'Η επιχείρηση έχει ζημία'

[B]ΜΕΤΑΒΛΗΤΕΣ[/B]
  [B]ΑΚΕΡΑΙΕΣ:[/B] i, j, k
  [B]ΠΡΑΓΜΑΤΙΚΕΣ:[/B] sales[12, EMPL], total_month[12], empl_3month[4, EMPL], total_3month[4], bonus[EMPL]
  [B]ΠΡΑΓΜΑΤΙΚΕΣ:[/B] sales_day, total_sales, total_bonus, net_profit

[B]ΑΡΧΗ[/B]
  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 12
    total_month[i] ← 0
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

[/B][B]  ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
    total_3month ← 0
    [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
      empl_3month_[i,j] ← 0
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
[/B]
  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
    bonus[i] ← 0
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 12
    [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
      sales[i,j] ← 0
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  total_sales ← 0
  total_bonus ← 0



  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 12
    [B]ΓΡΑΨΕ[/B] i, '-ος μήνας'
    [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
      [B]ΓΡΑΨΕ[/B] j, '-ος πωλητής'
      [B]ΓΙΑ[/B] k [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 3
        [B]ΓΡΑΨΕ[/B] 'Δώσε τις πωλήσεις του πωλητή για την ', k, '-η ημέρα του μήνα : '
        [B]ΔΙΑΒΑΣΕ[/B] sales_day
        sales[i,j] ← sales[i,j] + sales_day
      [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]



  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 12
    [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
      total_month[i] ← total_month[i] + sales[i,j]
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

[/B]  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 12
    [B]ΓΡΑΨΕ[/B] 'Οι συνολικές πωλήσεις τον ', i, '-o μήνα είναι ', total_month[i], ' ευρώ.'
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]



  [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
    [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
      [B]ΓΙΑ[/B] k [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 3
        empl_3month[i,j] ← empl_3month[i] + sales[3*(i-1) + k, j]
      [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
     [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
      [B]ΓΡΑΨΕ[/B] 'Ο τριμηνιαίος τζίρος για το ', i, '-o τρίμηνο του ', j, '-ου πωλητή είναι ', empl_3month[i, j], ' ευρώ.'
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]



  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
    [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 3
      total_3month[i] ← total_3month[i] + total_month[3*(i-1) + j]
     [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

   [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
     [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
       [B]AN[/B] empl_3month[i, j] > ΟΡΙΟ_BONUS [B]TOTE[/B]
          bonus[j] ← bonus[j] + BONUS_PERCENT*total_3month[i]
      [B]ΤΕΛΟΣ_ΑΝ[/B]
    [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
    ΓΡΑΨΕ 'Το bonus που θα πάρει ο ', j, '-ος πωλητής είναι ', bonus[j], ' ευρώ.'
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]



  [B]ΓΙΑ[/B] i [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] 4
    total_sales ← total_sales + total_3month[i]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΓΙΑ[/B] j [B]ΑΠΟ[/B] 1 [B]ΜΕΧΡΙ[/B] EMPL
    total_bonus ← total_bonus + bonus[j]
  [B]ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ[/B]

  [B]ΓΡΑΨΕ[/B] 'Η εταιρία θα εισπράξει συνολικά από τους πωλητές ', total_sales, ' ευρώ και θα δώσει σε bonus ', total_bonus, ' ευρώ.'


  net_profit ← total_sales - total_bonus
  [B]ΑΝ[/B] net_profit > TARGET [B]ΤΟΤΕ[/B]
    ΓΡΑΨΕ MSG1
  [B]ΑΛΛΙΩΣ[/B]
    ΓΡΑΨΕ MSG2
  [B]ΤΕΛΟΣ_ΑΝ[/B]
[B]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ[/B]

[I]Σημείωση: θεωρούμε ότι οι πωλήσεις είναι μη αρνητικοί αριθμοί[/I]
Εάν δείτε, σε αντίθεση με τις άλλες ασκήσεις, εδώ θεωρώ ότι δεν θα δωθεί "αρνητική" πώληση, άσχετα αν δεν λέει η εκφώνηση "θεωρούμε ότι θα δίνονται μη αρνητικές πωλήσεις". Αυτό γιατί χρησιμοποιούμε πίνακες. Στις περιπτώσεις αυτές θεωρούμε ότι θα δίνονται έγκυρα δεδομένα, εκτός κι αν ζητάει έλεγχο δεδομένων.


Ελπίζω να μην ξέχασα κάτι.
Mosteeeeeeeeeeeeeeeeel, με πέθανες. :P




Από Γιώργος
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

mostel

Πολύ δραστήριο μέλος

Ο Στέλιος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών , Φοιτητής και μας γράφει απο Θεσσαλονίκη (Θεσσαλονίκη). Έχει γράψει 1,203 μηνύματα.
Ωραία... (μη κοιτάς που έγραψα ωραία... δεν κάθησα να διαβάσω το τεράστιο αυτό μακαρόνι :P Θα το κοιτάξω αύριο με την ησυχία μου δια να αποφανθώ με "σύνεσιν και χωρίς φόβον και πάθος" :P)

Τώρα κάνε πρόγραμμα που να ελέγχει και για αρνητικές τιμές :P

Να διευκρινίσω ότι μιλάμε για πωλήσεις ΗΜΕΡΙΣΙΕΣ και για bonus 5% ανά κέρδη τριμήνου.

Τι θα λέγατε να τη δουλέψουμε μόνο με εντολές χωρίς πίνακες; ;)

PS: Ευχαριστώ τον ΓΙώργο που έδωσε τα ανωτέρω ελλείμματα που υπήρχαν στην εκφώνηση. Τώρα πλέον, με αυτές τις συμπληρώσεις, η άσκηση είναι ό,τι πρέπει για πανελλαδικές. :no1:


Επίσης, δοκιμάστε να κάνετε το διάγραμμα ροής.
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Τι θα λέγατε να τη δουλέψουμε μόνο με εντολές χωρίς πίνακες; ;)
Θα αστειεύεσαι, έτσι; :P





Δεν το μετατρέπεις σε C; :jumpy:
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

mostel

Πολύ δραστήριο μέλος

Ο Στέλιος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι 31 ετών , Φοιτητής και μας γράφει απο Θεσσαλονίκη (Θεσσαλονίκη). Έχει γράψει 1,203 μηνύματα.
Θα αστειεύεσαι, έτσι; :P





Δεν το μετατρέπεις σε C; :jumpy:

Γιατί ρε συ; Δεν έχει τόσο μεγάλη διαφορά... :P
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Γιώργος

Τιμώμενο Μέλος

Ο Γιώργος αυτή τη στιγμή δεν είναι συνδεδεμένος. Είναι Διδακτορικός και μας γράφει απο Ελβετία (Ευρώπη). Έχει γράψει 30,793 μηνύματα.
Γιατί ρε συ; Δεν έχει τόσο μεγάλη διαφορά... :P
Για να το τρέξω στο UNIX. ;)


ΓλωσσοΜάθεια δεν την εγκαθιστώ καν στο PC μου. Ποτέ φτηνά αποβράσματα της κοινωνίας. :P
 

Σημείωση: Το μήνυμα αυτό γράφτηκε 13 χρόνια πριν. Ο συντάκτης του πιθανόν να έχει αλλάξει απόψεις έκτοτε.

Status
Το θέμα δεν είναι ανοιχτό για νέες απαντήσεις.

Χρήστες Βρείτε παρόμοια

  • Τα παρακάτω 0 μέλη και 1 επισκέπτες διαβάζουν μαζί με εσάς αυτό το θέμα:
    Tα παρακάτω 0 μέλη διάβασαν αυτό το θέμα:
  • Φορτώνει...
Top