Ξαναγράψτε τον αλγόριθμο με χρήση δομής επανάληψης

Irenakiww

Νεοφερμένος

Η Irenakiww αυτή τη στιγμή δεν είναι συνδεδεμένη. Έχει γράψει μόλις ένα μήνυμα.
Γεια σας, εχω ψιλό κολλήσει και χρειάζομαι βοήθεια. Θα εκτιμούσα πολυ τον κόπο να προσφερθεί κάποιος να την λύσει

Να ξανά γράψετε τον παρακάτω αλγόριθμο χρησιμοποιώντας μόνο μια δομή επανάληψης Για..από..μέχρι.. χωρίς την χρήση δομή επιλογής και εντολών εκχώρησης.


για ι από 1 μέχρι Ν
Για j από 1 μέχρι Ν
αν ι=J τότε
Εμφάνισε Α[ι,j]
Τέλος_αν
Τέλος_επανάληψης
Τελος_επαναληψης
 

Κωνσταντίνος.Γ

Νεοφερμένος

Ο Κωνσταντίνος.Γ αυτή τη στιγμή δεν είναι συνδεδεμένος. Έχει γράψει 7 μηνύματα.
Λογικά θα μπορούσε να γίνει ως εξής
Για i από 1 μέχρι Ν
Γράψε Α[i,i]
Τελος_επαναληψης
Με το σκεπτικό ότι η κυρία διαγώνιος τυπώνει τα στοιχεία 1,1, 2,2 3,3 κ.ο.κ , είναι σκαλωτικο, εχοντας ρωτήσει φαίνεται μια καλή λύση και πολύ απλό , στην αρχή και γω δεν το βρήκα ρώτησα και γω ο ίδιος γιατί δεν μπορούσα , μια κατηγορία «λογικής» ασκήσεων ΑΕΠΠ όταν άκουσα αυτή την λύση μου φάνηκε αρκετα απλό .Ολα καλά απλά λίγο πονηριά παραπάνω θελουμε, καλή συνέχεια στον αγώνα μας παιδιά
 
Τελευταία επεξεργασία:

Χρήστες Βρείτε παρόμοια

  • Τα παρακάτω 0 μέλη και 1 επισκέπτες διαβάζουν μαζί με εσάς αυτό το θέμα:
    Tα παρακάτω 3 μέλη διάβασαν αυτό το θέμα:
  • Φορτώνει...
Top