×
Επεξεργασία Προφίλ Επεξεργασία Avatar Επεξεργασία Υπογραφής Επεξεργασία Επιλογών E-mail και Κωδικός
×
Αποσύνδεση Οι Συνδρομές μου Το Προφίλ μου Τα Posts μου Τα Threads μου Λίστα Επαφών Αόρατος Χρήστης
Αναζήτηση στο iSchool!
Τι;
Πως;
Ταξινόμηση
Που;
Σε συγκεκριμένη κατηγορία;
Ποιος;
Αποτελέσματα Αναζήτησης
Συμπληρώστε τουλάχιστον το πεδίο Τι;

Το iSchool είναι η μεγαλύτερη μαθητική διαδικτυακή κοινότητα με 66,851 εγγεγραμμένα μέλη και 2,411,460 μηνύματα σε 75,079 θέματα. Αυτή τη στιγμή μαζί με εσάς απολαμβάνουν το iSchool άλλα 234 άτομα.

Καλώς ήρθατε στο iSchool!

Εγγραφή Βοήθεια

Ξαναγράψτε τον αλγόριθμο με χρήση δομής επανάληψης

Irenakiww

Νεοφερμένος

H Irenakiww αυτή τη στιγμή δεν είναι συνδεδεμένη. Είναι 17 ετών . Έχει γράψει μόλις ένα μήνυμα.

H Irenakiww έγραψε: στις 12:22, 16-05-18:

#1
Γεια σας, εχω ψιλό κολλήσει και χρειάζομαι βοήθεια. Θα εκτιμούσα πολυ τον κόπο να προσφερθεί κάποιος να την λύσει

Να ξανά γράψετε τον παρακάτω αλγόριθμο χρησιμοποιώντας μόνο μια δομή επανάληψης Για..από..μέχρι.. χωρίς την χρήση δομή επιλογής και εντολών εκχώρησης.


για ι από 1 μέχρι Ν
Για j από 1 μέχρι Ν
αν ι=J τότε
Εμφάνισε Α[ι,j]
Τέλος_αν
Τέλος_επανάληψης
Τελος_επαναληψης
0 Δεν μπορείτε να αξιολογήσετε αρνητικά το μήνυμα αυτόΔεν μπορείτε να αξιολογήσετε θετικά το μήνυμα αυτό
Παράθεση

spinalgr1990 (Γιάννης)

Εκκολαπτόμενο Μέλος

Ο Γιάννης αυτή τη στιγμή δεν είναι συνδεδεμένος Έχει γράψει 69 μηνύματα.

O spinalgr1990 / έγραψε: στις 12:26, 16-05-18:

#2
για j<-N-i βαλε την 2η επαναληψη
0 Δεν μπορείτε να αξιολογήσετε αρνητικά το μήνυμα αυτόΔεν μπορείτε να αξιολογήσετε θετικά το μήνυμα αυτό
Παράθεση

Κωνσταντίνος.Γ

Νεοφερμένος

Ο Κωνσταντίνος.Γ αυτή τη στιγμή δεν είναι συνδεδεμένος Έχει γράψει 6 μηνύματα.

O Κωνσταντίνος.Γ έγραψε: στις 12:54, 17-05-18:

#3
Λογικά θα μπορούσε να γίνει ως εξής
Για i από 1 μέχρι Ν
Γράψε Α[i,i]
Τελος_επαναληψης
Με το σκεπτικό ότι η κυρία διαγώνιος τυπώνει τα στοιχεία 1,1, 2,2 3,3 κ.ο.κ , είναι σκαλωτικο, εχοντας ρωτήσει φαίνεται μια καλή λύση και πολύ απλό , στην αρχή και γω δεν το βρήκα ρώτησα και γω ο ίδιος γιατί δεν μπορούσα , μια κατηγορία «λογικής» ασκήσεων ΑΕΠΠ όταν άκουσα αυτή την λύση μου φάνηκε αρκετα απλό .Ολα καλά απλά λίγο πονηριά παραπάνω θελουμε, καλή συνέχεια στον αγώνα μας παιδιά
edited Τελευταία επεξεργασία από το χρήστη Κωνσταντίνος.Γ : 17-05-18 στις 13:04.
1 Δεν μπορείτε να αξιολογήσετε αρνητικά το μήνυμα αυτόΔεν μπορείτε να αξιολογήσετε θετικά το μήνυμα αυτό
Παράθεση
Απάντηση στο θέμα

Χρήστες

Βρείτε παρόμοια

Μοιραστείτε το

...με ένα φίλο

...με πολλούς φίλους